Exchange PowerShell Error

Well,
You start the Exchange Management Shell (EMS) after a regular Windows update, and boom, you’re end up with an error.
It says:
New-PSSession : Cannot find path ” because it does not exist
Then:
New-PSSession -ConnectionURI “$connectionUri” -ConfigurationName Micr …
And it tries all servers you’ve updated, and you end up with none functional EMS.

Ok,
1st, you shouldn’t update all servers without fully test the update on single one first, you should already know that by now.
2nd, yes it is indeed one of Microsoft products updates caused the crash of another Microsoft product.
3rd, most likely you didn’t update the product itself to the latest version.
4th, yes there is a solution, but it will cost you restarts.

So,
Check if you have the latest updates of Exchange, SharePoint, SQL, or any other application you have. And by checking I mean you check the version you have, and go to the website and find what is the latest version published and what is the latest update package (or cumulative update) is there.

If that is not an option, as I’m expecting from some Exchange and SharePoint admins, then you better start looking into each update installed on that day, and go read about it to find which one included modification and/or update of the PowerShell of the OS. You’ll need then to remove that update in order to test if the issue is gone, and if it’s not, then you’ll have to find the next update, and keep going till you find the one caused that issue.

Yes, I know it’s not much of a help.
However, you may want to check if the PowerShell 5.0 is installed on Exchange 2016 CU8 or earlier, or Exchange 2013 CU19 or earlier, then most likely you want to get back to PowerShell 4.x

Good luck,

اترك تعليقاً

لن يتم نشر عنوان بريدك الإلكتروني. الحقول الإلزامية مشار إليها بـ *